17th February 2019

Update Maintenance :: a2ss55

To ensure the long term stability and security of our servers, we are performing maintenance that involves significant software updates. We are currently applying these updates to the server A2SS55. While we have taken steps to minimize downtime during this update, it is reasonable to expect that brief service outages will occur. We will post updates as they become available.

Update 17 Feb 2019 5:10 AM - Maintenance on a2ss55 has been completed. If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.