15th February 2019

[RESOLVED]Update Maintenance :: a2ss39

To ensure the long term stability and security of our servers, we are performing maintenance that involves significant software updates. We are currently applying these updates to the server a2ss39. While we have taken steps to minimize downtime during this update, it is reasonable to expect that brief service outages will occur. We will post updates as they become available.

UPDATE 5:00 AM EDT: Maintenance on A2SS39 has been completed. If you experience any issues with the service, please do not hesitate to contact our Guru Crew for assistance.