23rd January 2019

[RESOLVED]Live chat maintenance

Start Time: 23 Feb 2019 07:00 AM Eastern

Estimated End Time: 23 Feb 2019 9:00 AM Eastern

Services Affected: Live Chat

Description: We will be conducting the Live Chat maintenance on Wednesday, January 23rd, between 7AM and 9AM Eastern. The service will be unavailable during that time period.

Update 7AMĀ Eastern: The maintenance has started. We will update this post once it's finished.

Update 9:48 AM Eastern: The maintenance has been completed as of approximately 8:30 AM EST and our live chat is back online at this time.