17th January 2019

[RESOLVED]mi3-ls14 :: Netowork issues

mi3-ls14.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 06:00 AM Eastern: The network issue has been resolved and we do not see any more problems.