16th January 2019

[RESOLVED] A2SS40 :: Service Interruption

A2SS40 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 19:10 EST A2SS40 is back online