8th January 2019

[RESOLVED]sg1-sr3 :: Inaccessible

sg1-sr3.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 05:45 AM Eastern: The server is back online