1st January 2019

[RESOLVED] SSR14 :: Service Interruption

wwwssr14.supercp.comĀ is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 8:45 AM - ssr14 is once again online and available. We will continue to monitor the service for any issues; future updates will be provided here as they become available.