17th December 2018

[RESOLVED]SSR20 :: Service Interruption

SSR20 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 11:55 PM EST: Engineers are still working to resolve issues with SSR20. We appreciate your patience in the mean time.

UPDATE 2:00 AM December 18th: The issue has been fixed and the server is back online.