4th December 2018

[RESOLVED] A2SS19 :: Service Interruption

A2SS19 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 7:35 PM EST: We are glad to report that A2SS19 is back online and working correctly.