3rd December 2018

[RESOLVED] SG Data Center Network

Our Singapore Data Center is currently experiencing intermittent service interruptions. Our Engineers are investigating the root cause of these interruptions. We will provide updates as more details are made available.

UPDATE 12:00AM: We are glad to report that the Singapore Data Center network has been stable and there have been no further issues.