23rd November 2018

[RESOLVED]src2.supercp.com service interruption

src2.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 7:00 AM Eastern: The issue has been fixed and the server is back online.