14th November 2018

[RESOLVED]mi3-lr1.supercp.com :: Service Interruption

mi3-lr1.supercp.comĀ is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 4:00 PM EST : Our System Operations team has resolved this issue and all services are online at this time.