10th November 2018

[RESOLVED]mi3-lr1 :: Service Interruption

mi3-lr1.supercp.comĀ is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 6:15 PM Eastern :: Service has been restored and sites are back online and operational.