10th November 2018

[RESOLVED] SSR23 :: Service Interruption

SSR23 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE As of 3PM This server is back up, please let us know if you are still having issues via phone, chat or in a ticket.