10th October 2018

[RESOLVED] SRC3 :: Service Interruption

The server SRC3 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 18:27 EST: We are glad to report that SRC3 is back online.