26th September 2018

[RESOLVED] MI3-SS35 :: Service Interruption

MI3-SS35 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 20:50 EDT: MI3-SS35 is back online and operating normally.