4th September 2018

[RESOLVED] A2SS20 :: Service Interruption

A2SS20 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 9:50 PM EDT: A2SS20 is back online and running normally.