23rd August 2018

[RESOLVED]my.a2hosting.com :: Service Interruption

My.a2hosting.com is currently experiencing a service interruption. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 12:15 PM EST : Our System Operations team has corrected this issue and my.a2hosting.com is now stable and operating as expected.