21st August 2018

[RESOLVED] Windows VPS Products :: Service Interruption

Windows VPS servers are currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 5:10PM EST: Our teams have resolved this issue and all Windows VPS products are back online.

Update 6:10PM EST: We've found that there are still systems offline that were not previously apparent. Engineers are working to restore service to all Windows VPS servers as quickly as possible.

Update 8:20PM EST: Most VPSs are back online. We are working to make sure that service is restored to all VPSs before we close this status.

Update 8:55PM EST: We are glad to repor that all VPS issues have been resolved. Please contact our support if you experience any further issues.