20th August 2018

[RESOLVED]src2.supercp.com service disruption

src2.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 04:15 Am EDT: The server is back online now.