17th August 2018

[RESOLVED]nlsrc3.supercp.com : Service Interruption

nlsrc3.supercp.com is currently experiencing a service disturbance. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 2:10 PM EST : Our System Operations team has corrected this matter and the server is now operating as expected.