15th August 2018

[RESOLVED]mi3-ss34 :: Service Interruption

mi3-ss34.a2hosting.comĀ is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 8:07 AM EST : Our System Operations team has corrected this matter and the services are now operating as expected.