30th July 2018

[RESOLVED]a2s57.a2hosting.com :: Service Interruption

a2s57 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is currently working on this issue. We will provide updates as more details are made available.

UPDATE 1:45 PM EST: The server is now online and operational.