29th July 2018

[RESOLVED]mi3-wss9.a2hosting.com Plesk Login Issues

We are currently experiencing issues with Plesk on our Windows server mi3-wss9.a2hosting.com. This is also impacting customers situated on that server from accessing account information pages within the Client Area. Our technicians are currently working to correct this issue.

UPDATE 1:30PM EST - our team is continuing to work on the Plesk issue to bring that service back online. We will continue to post updates as they become available. Thank you for your patience as we work to resolve this. UPDATE 4:53PM EST - Our system operations teams continues to work on restoring the Plesk service. We will post additional updates as they become available. UPDATE 5:07PM EST - We are pleased to announce that the Plesk service has been restored and is now functioning properly.