26th July 2018

[RESOLVED] A2SS30 :: Service Interruption

A2SS30 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 4:40 PM EST: A2SS30 is back online and working properly.