22nd September 2017

ssr8.supercp.com :: Reboot

9/25 2:00AM Eastern - ssr8.supercp.com will be going through a routine maintenance reboot. Users will experience a 1-5 minute downtime.

Update 3:00 AM EDT: The server is still being worked on by our system engineers

Update 3:50 AM EDT: The server is back online