8th July 2018

[RESOLVED]Amsterdam Data-center Connectivity

We are currently investigating complaints that a small set of users are unable to connect to their sites and control panels in our Amsterdam Datacenter. The sites and servers are online but are unreachable for some users. We will post more updates as they become available.

Update 22:00 Eastern :: We are glad to report the issue has been resolved and we have received no additional complaints. Thank you for your patience.