6th July 2018

[RESOLVED]mi3-ss16 :: Service Interruption

mi3-ss16.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 10:00 AM EST :: Our System Operations team has corrected this issue and services are now online. We will continue to monitor the server for stability.