4th July 2018

[RESOLVED]mi3-wss3.a2hosting.com :: Service Interruptio

mi3-wss3.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 9:50 AM EST :: Our system operations team has corrected this matter and will continue to monitor the server for stability.