1st July 2018

[RESOLVED] wwwssr22.supercp.com :: Service Interruption

ssr22.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 12:15 AM EST :: Our system operation team has corrected this issue and services are now online. We will continue to monitor the server for stability.