7th June 2018

[RESOLVED]ssr11.supercp.com service interruption

ssr11.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 05:00 AM EDT: The server is still being worked on by our system engineers

UPDATE 05:45 AM EDT: The server is back online