6th June 2018

[RESOLVED]mi3-ss18.a2hosting.com service interruption

mi3-ss18.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 5:45 AM EDT: The server is back online