3rd June 2018

[RESOLVED]mi3-wss1 :: FTP Interruption

We are currently aware of an issue with FTP not accepting connections on mi3-wss1.a2hosting.com and we our currently investigating the issue. We will provide updates as they become available.

UPDATE 20:28 Eastern :: Our System Operations team continues to look into the issue and we will post more updates as they become available

UPDATE 21:45 Eastern :: We are happy to announce the FTP service is back online and functional.