24th May 2018

[RESOLVED]a2s74.a2hosting.com MySQL maintenance

a2s74.a2hosting.com is currently undergoing an emergency MySQL maintenance. Users hosted on this server will experience service degradation as a result. We will provide updates as more details are made available.

Update 4:20 AM EDT: The maintenance has been completed and the service is back up now