15th May 2018

[RESOLVED]SGSSR1 :: Service Interruption

SGSSR1 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 01:20 AM EDT: The server is still being worked on by our system administrators.

Update 01:40 AM EDT: The server is back online now.