15th May 2018

[RESOLVED]mi3-ss6.a2hosting.com service inter

mi3-ss6.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

Update 6:10 AM EDT: The server and all services are back online.