10th May 2018

[RESOLVED] mi3-ss15 :: Service Interruption

MI3-SS15 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 19:10 EDT: MI3-SS15 is back online.