22nd June 2022

[RESOLVED] mi3-ts12 :: Service Interruption

mi3-ts12.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 2:45 PM EDT: Our Engineers team was able to identify the issue affecting the server and correct it. Please let us know if you're still experiencing any issues.