21st June 2022

[COMPLETED] Netherlands Backup Power Scheduled Maintenance

Start Date: Tuesday, June 21, 2022

End Date: Tuesday, June 22, 2022

Time: 8:00 PM - 05:00 AM GMT (3:00 PM - 00:00 EDT)

Description: Our Datacenter team will perform maintenance in our Netherlands Datacenter. Users on designated hardware may experience a brief service interruption while routine maintenance is performed. We will provide updates as they're made available.

As of 15:00 EDT:: This Maintenance is now in progress.  We will update you as we know more.

UPDATE 1:50 AM EDT, Jun-22: This maintenance has been completed at this time. Please reach out to our support team should you encounter any issues.