10th June 2022

[COMPLETED] Michigan Datacenter :: Scheduled Maintenance

Start Date: Friday, June 10, 2022

End Date: Saturday, June 11, 2022

Time: 10:00 PM - 02:00 EDT

Description: Our Engineering team will perform maintenance in our Michigan Datacenter. Users on designated hardware may experience a brief service interruption while routine maintenance is performed. We will provide updates as they're made available.

UPDATE 10:00 PM EDT: Our Engineers are starting the maintenance. We will post updates as more information becomes available in this regard.

UPDATE 11:00 PM EDT: Our Engineers are still working on the hardware. We will post updates as more information becomes available in this regard. We sincerely appreciate your patience and understanding in this regard.

UPDATE 12:15 AM EDT: Our Engineers continue working on the hardware. Further updates will be provided as this maintenance continues.