13th May 2022

[COMPLETED] Michigan Datacenter :: Network Maintenance

Our Network Engineering team will be performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while routine maintenance is performed. We will provide updates as they're made available. 

UPDATE 12:00AM EDT: Our Engineers have started the maintenance. We will post updates as we make progress. We sincerely appreciate your patience and understanding in the meanwhile.UPDATE 2:20 AM EDT: Our Engineers are still working on this. We will post updates as more information becomes available.

UPDATE 05:00 AM EDT: Our Engineers are still working on the maintenance. Customers with services connected to the Michigan datacenter may experience slowness or short service interruption during this time. We really appreciate your understanding and patience in this regard.

UPDATE 5:55AM EDT: Maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.