14th January 2022

Amsterdam Data Center :: Intermittent Speed & Connectivity Issues

Our Network Engineering team is currently investigating reports of intermittent connectivity & speed issues in our Amsterdam data center. Our Network Engineering team is aware of this issue and working diligently to rectify the situation. We will provide further updates as they're made available.

UPDATE 10:46 AM EST: Our Network Engineering team made an adjustment to address the intermittent connectivity and speed issues in our Amsterdam data center. We will continue to monitor the network and situation closely. Please contact our Support team directly if you continue to experience issues.

UPDATE 11:13 AM EST: Our Network Engineering team is investigating further intermittent connectivity & speed issues in our Amsterdam data center.

UPDATE 12:27 PM EST: Our Network Engineering team is still investigating intermittent connectivity and speed issues in our Amsterdam data center. We will provide further updates as they're made available.

UPDATE 2:24 PM EST: Our Network Engineering team continues to work toward resolving intermittent connectivity and speed issues in our Amsterdam data center. We will provide further updates as they're made available.

UPDATE 4:50 PM EST: Our Network Engineers are still working on the issue. We will update this thread as more information becomes available. We sincerely appreciate your patience and understanding in this regard.

UPDATE 11:00PM EST: Our team is making progress in terms of reducing the impact. However, we are continuing our efforts to ensure services are fully restored for all impacted clients. We sincerely appreciate your continued patience and understanding in this matter.

UPDATE 1:45 AM EST, January 14th: Our Network Engineering team continues to work toward resolving intermittent connectivity and speed issues in our Amsterdam data center. We will provide further updates as they're made available.

UPDATE 4:00 AM EST, January 14th: Our Network Engineers are still working on these intermittent connectivity and speed issues. We will update this thread as more information becomes available. We sincerely appreciate your patience and understanding in this regard.

UPDATE 6:20 AM EST, January 14th: Our Network Engineers are aware of reports of network interruption faced by some of our clients. Our Network Engineers are working on this. We will continue to provide updates as more information is available.

UPDATE 11:15 AM EST, January 14th: Our Network Engineers resolved this matter at approximately 9:15 AM EST. We will continue to monitor the situation closely. If you're experiencing any outstanding speed or connectivity issues please contact our Support team directly.

UPDATE 12:55 PM EST, January 14th: Our Network Engineers are aware of reports of timeout errors with Cloudflare and other external sources. Our Network Engineers are working on this. We will continue to provide updates as more information is available.

UPDATE 2:30 PM EST, January 14th: Our Network Engineers made an adjustment to address any remaining connectivity or speed issues to Cloudflare and other external sources. We will continue to monitor the situation closely. If you're experiencing any outstanding speed or connectivity issues please contact our Support team directly.