2nd January 2022

[RESOLVED]Arizona Network Maintenance

Start Date: Sunday, January 2, 2022

End Date: Sunday, January 2, 2022

Start Time: 4:00 AM EST

End Time: 6:00 AM EST

Services Affected:

Arizona Data Center

Description: This maintenance is from one of our network service providers in Arizona. Users may experience a brief service interruption while the maintenance is performed.

Update 6:00 AM EST: The maintenance period is complete, services are once again available.