2nd May 2018

Email Connectivity

sr1.supercp.com through sr8.supercp.com are currently experiencing an interruption in email service. Users will experience service degradation as a result.

Update 11:48AM Eastern:: This issue has been resolved and we will continue to monitor the servers for email stability.

Update 12:10PM Eastern:: Our engineers are investigating reports of connectivity issues with mail.

Update 2:38PM Eastern:: Our engineers have implemented a fix and this has been tested to be working for longer than two hours. We will continue to monitor the server for stability.