8th December 2021

[COMPLETED] Arizona & Amsterdam Network Maintenance

Start Date: Thursday, December 9, 2021

End Date: Friday, December 10, 2021

Start Time: 9:00 PM EST

End Time: 1:00 AM EST

Services Affected:

Arizona Data Center

Amsterdam Data Center

Description: Our Network Engineering team will be performing network maintenance in our Arizona and Amsterdam Datacenter. Users may experience a brief service interruption while the routine maintenance is performed.

UPDATE 9:00PM EST: Maintenance has been started as per schedule. We will update this thread as more information becomes available. We sincerely appreciate your patience and understanding in this matter.

UPDATE 10:20PM EST: Maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.