30th April 2018

[RESOLVED] Intermittent DNS Issues

Our Engineering team is investigating the root cause of an interruption of DNS outages. We will provide updates as more details are made available.

Update 1:30PM EST :: Our Engineers are still investigating this matter and are working on implementing a fix to this problem.

Update 3:25PM EST :: Our Engineers have identified the root cause of this issue and are working on resolving the issue as quickly as possible.

Update 5:40PM EST :: Engineering has concluded that this issue has been resolved for the time being. If further issues are experienced, we will re-open this notice.