26th November 2021

Sectigo SSL Certificates :: Degraded Performance

We're currently seeing Sectigo is experiencing degraded performance with issuing SSL Certificates. Users will experience delays with free SSL certificates being issued or renewed as a result.  We're looking into this issue and we will provide updates as we know more.

As of 1:30PM EST :: This issue is still being investigated and we are currently still working on this.  We will provide updates as soon as we know more.

UPDATE 6:25AM EST, November 24th: Our Engineers continue to work to try and resolve the issues with SSL certificates issuance. It means SSL generation will be slower than normal. If you have any difficulties then please reach out to our team and we'll work with you to resolve this.

UPDATE 4:25AM EST, November 26th: There is still a problem with issuing SSL certificates. In case you have any difficulties with issuing/renewal your SSL certificates, then please reach out to our team and we'll work with you to resolve this.