16th November 2021

[COMPLETED] Michigan Network Maintenance

Start Date: Wednesday, November 17th, 2021

End Date: Thursday, November 18th, 2021

Start Time: 10:00 PM EST

Services Affected:

Michigan Data Center

Description: Our Network Engineering team will be performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while the routine maintenance is performed.

UPDATE: This maintenance has been completed on schedule