7th October 2021

[COMPLETED]Michigan Network Maintenance

Start Date: Thursday, October 7th, 2021

End Date: Thursday, October 7th, 2021

Start Time: 1:30 PM EST

Services Affected:

Michigan Data Center

Description: Our System Operations team will be performing network maintenance in our Michigan Datacenter. Users may experience a brief service interruption while the routine maintenance is performed.

UPDATE 1:37 PM EST: Our System Operations team completed the maintenance.