7th October 2021

[COMPLETED] Michigan Network :: Scheduled Maintenance

Start Date: Monday, October 7th, 2021

End Date: Monday, October 7th, 2021

Start Time: 12:00 AM GMT-7 (3:00 AM EST)

Services Affected:

Michigan Data Center

Description: Our System Operations team will be performing scheduled maintenance in our Michigan Datacenter. Users may experience a brief service interruption while the routine scheduled maintenance is performed.

UPDATE 04:14 AM EST: Maintenance is completed.